Enrutamiento estático en Packet Tracer

ELEMENTOS DE UNA RED

Enrutamiento estático

La tabla de enrutamiento contiene la información más importante que usan los routers. Esta tabla proporciona la información que usan los routers para reenviar los paquetes recibidos. Si la información de la tabla de enrutamiento no es correcta, el tráfico se reenviará incorrectamente y posiblemente no llegue al destino. Para que se comprendan las rutas de tráfico, la resolución de problemas y la manipulación del tráfico, es absolutamente necesario que se tengan conocimientos sólidos sobre cómo leer y analizar una tabla de enrutamiento. El enrutamiento estático proporciona un método que otorga a los ingenieros de redes control absoluto sobre las rutas por las que se transmiten los datos en una internetwork. Para adquirir este control, en lugar de configurar protocolos de enrutamiento dinámico para que creen las tablas de enrutamiento, se crean manualmente. Es importante entender las ventajas y desventajas de la implementación de rutas estáticas, porque se utilizan extensamente en internetworks pequeñas y para establecer la conectividad con proveedores de servicios. Es posible que se crea que el enrutamiento estático es sólo un método antiguo de enrutamiento y que el enrutamiento dinámico es el único método usado en la actualidad. Esto no es así, además, se destaca que escribir una ruta estática en un router no es más que especificar una ruta y un destino en la tabla de enrutamiento, y que los protocolos de enrutamiento hacen lo mismo, sólo que de manera automática. Sólo hay dos maneras de completar una tabla de enrutamiento: manualmente (el administrador agrega rutas estáticas) y automáticamente (por medio de protocolos de enrutamiento dinámico). Las rutas sumarizadas y las rutas estáticas por defecto permiten que los administradores reduzcan significativamente el tamaño de las tablas de enrutamiento. Como la tabla de enrutamiento contiene la información más importante para el router, la tabla debe completarse eficazmente.

Ventajas de usar enrutamiento estático

El uso de rutas estáticas y sumarizadas por defecto hace que el proceso de enrutamiento sea más eficaz. Concretamente, las tablas de enrutamiento más pequeñas reducen el tiempo de búsqueda de rutas y el uso del procesador, y aceleran el reenvío de paquetes.

Cuadro comparativo enrutamiento estático vs enrutamiento dinámico

Cuadro comparativo enrutamiento estático y dinámico

Topología de ejemplo

Para este ejemplo construimos la siguiente topología en la cual unimos dos redes mediante un cable Serial.

Enrutamiento Estático

Configuración enrutamiendo estático en cada router

Nota: Se debe ejecutar solo los comandos marcados en negrita.

Router 1:

System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)

Copyright (c) 2000 by cisco Systems, Inc.

PT 1001 (PTSC2005) processor (revision 0x200) with 60416K/5120K bytes of memory

Readonly ROMMON initialized

Self decompressing the image :

########################################################################## [OK]

Restricted Rights Legend

Use, duplication, or disclosure by the Government is

subject to restrictions as set forth in subparagraph

(c) of the Commercial Computer Software – Restricted

Rights clause at FAR sec. 52.227-19 and subparagraph

(c) (1) (ii) of the Rights in Technical Data and Computer

Software clause at DFARS sec. 252.227-7013.

cisco Systems, Inc.

170 West Tasman Drive

San Jose, California 95134-1706

Cisco Internetwork Operating System Software

IOS ™ PT1000 Software (PT1000-I-M), Version 12.2(28), RELEASE SOFTWARE (fc5)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2005 by cisco Systems, Inc.

Compiled Wed 27-Apr-04 19:01 by miwang

PT 1001 (PTSC2005) processor (revision 0x200) with 60416K/5120K bytes of memory

.Processor board ID PT0123 (0123)

PT2005 processor: part number 0, mask 01

Bridging software.

X.25 software, Version 3.0.0.

4 FastEthernet/IEEE 802.3 interface(s)

2 Low-speed serial(sync/async) network interface(s)

32K bytes of non-volatile configuration memory.

63488K bytes of ATA CompactFlash (Read/Write)

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: n

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface FastEthernet0/0

Router(config-if)#ip address 192.168.1.1 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#interface Serial2/0

Router(config-if)#ip address 10.0.0.2 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial2/0, changed state to down

Router(config-if)#

Router(config-if)#exit

Router(config)#

%LINK-5-CHANGED: Interface Serial2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config)#ip route 192.168.2.0 255.255.255.0 10.0.0.3

Router#

%SYS-5-CONFIG_I: Configured from console by console

Router 2                                                              

System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)

Copyright (c) 2000 by cisco Systems, Inc.

PT 1001 (PTSC2005) processor (revision 0x200) with 60416K/5120K bytes of memory

Readonly ROMMON initialized

Self decompressing the image :

########################################################################## [OK]

Restricted Rights Legend

Use, duplication, or disclosure by the Government is

subject to restrictions as set forth in subparagraph

(c) of the Commercial Computer Software – Restricted

Rights clause at FAR sec. 52.227-19 and subparagraph

(c) (1) (ii) of the Rights in Technical Data and Computer

Software clause at DFARS sec. 252.227-7013.

cisco Systems, Inc.

170 West Tasman Drive

San Jose, California 95134-1706

Cisco Internetwork Operating System Software

IOS ™ PT1000 Software (PT1000-I-M), Version 12.2(28), RELEASE SOFTWARE (fc5)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2005 by cisco Systems, Inc.

Compiled Wed 27-Apr-04 19:01 by miwang

PT 1001 (PTSC2005) processor (revision 0x200) with 60416K/5120K bytes of memory

Processor board ID PT0123 (0123)

PT2005 processor: part number 0, mask 01

Bridging software.

X.25 software, Version 3.0.0.

4 FastEthernet/IEEE 802.3 interface(s)

2 Low-speed serial(sync/async) network interface(s)

32K bytes of non-volatile configuration memory.

63488K bytes of ATA CompactFlash (Read/Write)

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: n

Press RETURN to get started!

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface FastEthernet0/0

Router(config-if)#ip address 192.168.2.1 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#interface Serial2/0

Router(config-if)#ip address 10.0.0.3 255.0.0.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface Serial2/0, changed state to up

Router(config-if)#exit

Router(config)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config)# ip route 192.168.1.0 255.255.255.0 10.0.0.2

Nota final:

Recuerda asignar direcciones ip a cada computador, ya que si no lo haces no podrán comunicarse con la red interna y mucho menos con la red vecina.