Conectar dos redes mediante protocolo RIP, enrutamiento dinámico en Packet Tracer

REDES POR SU USO

En el ámbito de las redes los protocolos juegan un papel fundamental, permitiéndonos realizar una multitud de acciones, en este artículo veremos como conectar dos redes haciendo uso del protocolo RIP (Enrutamiento dinámico),  para lo cual utilizaremos Packet Tracer, en el cual realizaremos la simulación de la red.

¿Que es el protocolo RIP?

El protocolo RIP (Routing Information Protocol) se basa en el algoritmo de vector de distancia que permiten a los Routers intercambiar información sobre las posibles rutas o destinos a lo largo de toda la red.

El algoritmo de vector de distancia hace que los routers difundan periódicamente sus tablas de routing a todos sus routers vecinos. De esta forma, el router, al conocer las tablas de todos sus vecinos, puede decidir por donde debe enviar cada paquete

Conectar dos redes mediante protocolo RIP (Enrutamiento dinámico)

A continuación veamos paso a paso como podemos conectar dos redes haciendo uso del protocolo RIP, empecemos:

Primero que todo armaremos la siguiente topología:

Dispositivos: 2 Router-PT, 2 Switch2960 24TT, 4 PC-PT (Dos para cada red).

Conectar dos redes protocolo RIP

 

Procedemos a tender los cables directos (Copper Straight-Through) desde los computadores hacia los Switch y del Switch al router de cada red, así mismo conectamos cada router con un cable Serial DTE, en sus puertos Consola:

 

Conectar dos redes RIP

Luego de contar con el cableado tendido en nuestra topología, procedemos a configurar las direcciones IP para los computadores de cada red:

A continuación la configuración de red de cada computador:

Configuración de red packet tracer

¿Como configuro cada computador?:

Configurar ip en computador packet tracer

Este proceso debemos repetirlo para todos los computadores de ambas redes, asignando las direcciones IP correspondientes.

Configuración en cada Router

Esta es la parte más importante en la configuración lógica de nuestra red para lo cual debemos tener presente:

  • El nombre de la interfaz donde conectamos nuestros cables.
  • Podemos saber el nombre de nuestras interfaces colocando el mouse encima de los nodos rojos y verdes.
  • Si nos equivocamos en un comando no debemos repetir todo, tan solo escribimos nuevamente el comando errado.
  • Los nodos que están en rojo indican que la interfaz está apagada.

Nombres de los nodos en la topología

Nodos packet tracer

Configuración de red para el Router Número 1 (Red 1):

Hacemos clic en el primer router y nos dirigimos a la pestaña CLI:

Nos preguntará: Continue with configuration dialog? [yes/no]:

Aquí escribimos no y presionamos enter.

Configurar Interfaz FastEthernet del Router 1.

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface FastEthernet0/0

Router(config-if)#ip address 192.168.1.1 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

En las líneas anteriores asignamos una dirección IP a la interfaz de red FastEthernet0/0 (Que es la interfaz que actuará como puerta de enlace en la red), y luego la encendemos.

Configurar Interfaz Serial en Router 1

Router(config)#interface Serial2/0

Router(config-if)#ip address 10.0.0.2 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial2/0, changed state to down

Router(config-if)#exit

Al igual que la interfaz Fa0/0, asignamos una dirección IP a nuestra interfaz serial y la encendemos, esta interfaz está conectada al router de la red 2.

Configurar protocolo RIP en Router 1

Router(config)#router rip

Router(config-router)#network 192.168.1.0

Router(config-router)#network 10.0.0.0

Router(config-router)#exit

Router(config)#exit

Router#

%SYS-5-CONFIG_I: Configured from console by console

Router#write

Building configuration…

[OK]

Router#

En esta parte configuramos el protocolo RIP, indicando las dos redes, tanto la red privada como la red publica, de esta forma el router podrá definir donde enviar los paquetes, importante escribir el comando write para guardar todas las configuraciones.

Configuración completa del router 2:

A continuación la configuración realizada en el router 2, no será detallada como la anterior debido a que los comandos son idénticos solo cambiando las direcciones IP.

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface FastEthernet0/0

Router(config-if)#ip address 172.16.5.1 255.255.0.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#interface Serial2/0

Router(config-if)#ip address 10.0.0.3 255.0.0.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface Serial2/0, changed state to up

Router(config-if)#exit

Router(config)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config)#router rip

Router(config-router)#network 172.16.5.0

Router(config-router)#network 10.0.0.0

Router(config-router)#exit

Router(config)#exit

Router#

%SYS-5-CONFIG_I: Configured from console by console

Router#write

Building configuration…

[OK]

Router#

Comprobando conexión entre ambas redes:

Enviando paquetes por las herramientas de Packet Tracer:

Enviar paquetes packet tracer

Vemos como en la parte inferior aparece Successful, indicando que el proceso de envío se realizó correctamente.

Haciendo ping de un equipo a otro que se encuentra en la otra red

Otra forma de verificar si hay conexión es con el comando ping, para ello nos dirigimos al primer computador de la red 1 y haremos ping a la dirección IP 172.16.5.3 (Que es de un equipo de la red 2), así:

Comando ping packet tracer

De esta forma podemos verificar las conexiones entre las redes.

Por último una imagen con la dirección configurada en cada interfaz:

Protocolo RIP