Definir mayor y menor de una lista de números Algoritmo en PSeInt

Ciencia, Algoritmos

En el presente ejercicio abarcaremos el manejo de condiciones dentro de un ciclo repetitivo, concretamente dentro de un ciclo Mientras, esto con el fin de entender el manejo de los valores tomados por las variables de control y acumuladora que lleguen hacer parte de la lógica del algoritmo en cuestión, para el presente ejemplo realizaremos un algoritmo para definir mayor y menor de una lista de números, veamos entonces su desarrollo.

Definir mayor y menor de una lista de números Algoritmo en PSeInt

Caso estudio: Construir un algoritmo con la capacidad de definir mayor y menor de una lista de números, para este ejercicio no será necesario hacer uso de arreglos.

Datos de entrada

  • Cantidad de números que el usuario desea ingresar (Inicialmente indeterminada).
  • Números ingresados por el usuario.

Procesos

  • Solicitar la cantidad de números.
  • Pedir la cantidad de números deseados por el usuario (Con un ciclo).
  • Almacenamos el primer número en cada variable: may y men.
  • Comparamos los números.

Salidas

  • Imprimir en pantalla el menor de los números ingresados.
  • Imprimir en pantalla el mayor de los números ingresados.

El el siguiente vídeo, podrás encontrar paso a paso la solución a este ejercicio.

📌 Puedes descargar este algoritmo aquí

🛡 Los ataques informáticos crecen cada día
YouTube IconProtege tus Dispositivos - Usa Kaspersky Antivirus.

Vídeo relacionado: 🔷 Almacenar N números en un ARREGLO y DEFINIR el MAYOR y MENOR en PSeInt | DIMENSIONES en PSeInt 💡

En el código anterior es importante tener claro que, posterior al solicitar la cantidad de números entramos al ciclo para empezar a pedirlos, sin embargo en la primera vuelta del ciclo (Cuando «i» vale «1«); no tenemos con quién comparar los números por lo cual simplemente a las variables, (men y may), asignamos los valores del primer número ingresado, para posteriores iteraciones, si comparamos el valor almacenado en cada variable (men y may), de esta manera determinar si el nuevo número ingresado es mayor o menor, finalmente de ser verdaderas estas condiciones, reemplazamos el valor de cada variable con el nuevo número, ejemplo de una posible salida del algoritmo.

*** Ejecución Iniciada. ***
¿Cuantos números ingresará?
> 4
Ingrese el número: 1
> 8
Ingrese el número: 2
> -1
Ingrese el número: 3
> 2
Ingrese el número: 4
> 5
El menor de los números ingresados es: -1
El mayor de los números ingresados es: 8
*** Ejecución Finalizada. ***

De esta forma logramos de una lista de números con una cantidad «indeterminada inicialmente», definir mayor y menor; aplicando condicionales dentro de un ciclo repetitivo para reemplazar el valor de una variable según una condición.

8 comentarios

  1. Sebastian Contestar

    Hola bro, tengo una pregunta boba, que significa «i» y «t». Las otras variables si se que son.

    • Ivan David Lopez Contestar

      La variable i es de control, para poder finalizar el ciclo. mientras que la variable t es utilizada para capturar los números en cada iteración, le puse t por «temporal».
      Saludos!

  2. Uziel Contestar

    Hice lo mismo con For y con Do-Until, pero con Do-Until cuando ingreso 5 valores solo me da el de 4, por ejemplo: 1,2,3,4 y 5. Se supone que al final me debería aparecer que el 5 es el mayor y el 1 el menor, pero me aparece que el 2 es el menor, y no es correcto. Te dejo el código, solo cambie algunas variables.
    Algoritmo Diagrama2_CicloDo
    may <- 0
    men <- 0
    i <- 1
    N <- 0
    Escribir 'Ingresar numeros enteros'
    Leer N
    Repetir
    Escribir 'Ingrese el numero:",i
    Leer num
    Si i=1 Entonces
    may <- num
    men may Entonces
    may <- num
    FinSi
    Si num<men Entonces
    men <- num
    FinSi
    FinSi
    i =N
    Escribir ‘El mayor es:’,may
    Escribir ‘El menor es:’,men
    FinAlgoritmo

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *