Qué son estructuras condicionales | DICCIONARIO DE ALGORITMOS

Quiero darte la bienvenida al diccionario de algoritmos, donde aprenderás de forma rápida y en un lenguaje sencillo, términos comunes, que están relacionados con algoritmos y programación; tener conceptos básicos claros, será fundamental en tu aprendizaje. Por lo tanto, te invito a suscribirte, para recibir más vídeos de este diccionario de algoritmos. Una de las necesidades de un Software, son los condicionales; las estructuras condicionales están presentes en todos los programas y algoritmos de mediana y alta complejidad, permitiendo de cierta forma “Tomar decisiones”.

Qué son estructuras condicionales | DICCIONARIO DE ALGORITMOS

Definición: un condicional, es una estructura o código que permite, determinar el flujo de ejecución de un algoritmo o Software, por lo tanto, si una condición se cumple, podrá ejecutar o no ciertos bloques de instrucciones.

Ejemplos de condiciones en la vida cotidiana

Sin darnos cuenta, todos los días estamos interactuando con condiciones; veamos algunos ejemplos de condiciones que quizá ya conoces.

  • Llego en 15 minutos “si las calles no están congestionadas”.
  • El descuento en la compra es del 5%, si compras más de 100.000.
  • Si tu nota es de mínimo 3 puntos ganas la materia, sino la pierdes.

Estos son solo ejemplos de condiciones que en un contexto real, son comunes, sin embargo en representados en programación y algoritmos, uno podrán ser más complejos que otro.

Las estructuras condicionales en algoritmos y programación podemos encontrarlas de varios tipos, cómo lo son: simples, dobles y anidadas.

Veamos a continuación ejemplos y detalles de cada uno de estos tipos de condicionales.

Condicionales simples

Este tipo de condicional, se caracteriza por establecer una sola condición a evaluar, con el fin de ejecutar o no un bloque de código; es uno de los condicionales más sencillos.

Ejemplo de condicional simple

Veamos un ejemplo, dónde solicitamos un nombre y verificamos si es iguala a “Ana”, daremos los buenos días, solo si el nombre ingresado es Ana.

Algoritmo Condicional_Simple
                Definir nombre Como Caracter
                Escribir "Ingrese su nombre"
                leer nombre
                Si nombre == "Ana" Entonces
                     Escribir "Buenos días Ana!"
                FinSi
FinAlgoritmo

Representación de un condicional simple en diagrama de flujo

Qué son estructuras condicionales

Cómo podemos observar, la ejecución del algoritmo solo tiene una vía; en caso de ingresar un nombre, diferente a “Ana”, no se mostraría nada el ejecutarlo.

Condicionales dobles

Cuando hablamos de condicionales dobles, podemos tener dos alternativas para la ejecución del código, en el condicional que establecemos; básicamente es definir que se hace, cuando la condición es falsa.

Ejemplo de condicional doble

Algoritmo Condicional_Doble
                Definir nombre Como Caracter
                Escribir "Ingrese su nombre"
                leer nombre
                Si nombre == "Ana" Entonces
                        Escribir "Buenos días Ana!"
                SiNo
                        Escribir "Hola ", nombre,", No te conozco!"
                FinSi
FinAlgoritmo

Representación de un condicional doble en diagrama de flujo

Qué son estructuras condicionales

Cómo podemos observar, tanto cuando la condición es evaluada como verdadera o como falsa, el algoritmo siempre mostrará un resultado.

Condicionales anidados

Los condicionales anidados, permiten escribir una condición dentro de otra; todas las veces que sea necesario, según las comprobaciones requeridas en el algoritmo, es como hacer múltiples preguntas.

Ejemplo de condicionales anidados

Algoritmo Condicional_Doble
                Definir nombre Como Caracter
                Escribir "Ingrese su nombre"
                leer nombre
                Si nombre == "Ana" Entonces
                               Escribir "Buenos días Ana!"
                               Escribir "¿Pagaste la renta?: Si o No"
                               leer renta
                               Si renta=="Si" Entonces
                               Escribir "Excelente, estás al día"
                               SiNo
                               Escribir "Ana, debes esforzarte más"
                               FinSi
                SiNo
                        Escribir "Hola ",nombre,", No te conozco!"
                FinSi
FinAlgoritmo

Representación de un condicionales anidados en diagrama de flujo

Condicionales dobles en algoritmos

Para el caso de los condicionales anidados, podemos observar, que un condicional puede estar dentro de otro; tanto cuando es verdadera o cuando es falsa la evaluación de una condición; la segunda condición que pregunta si pagó la renta, solo se evalúa, si el nombre es iguala a “Ana”.

Finalmente, comprendemos lo que son estructuras condicionales en algoritmos y programación; así como los tipos que existen.

Si deseas aprender más acerca del uso de variables, puedes acceder al CURSO DE ALGORITMOS con PSeInt; dónde te explicaré paso a paso, el uso de variables y otras temáticas referentes a algoritmos.

Deja una respuesta

Tu dirección de correo electrónico no será publicada.

*

code