Para en Algoritmos “Ciclo Repetitivo” – Uso y Función

Algoritmos

Preliminares Ciclo para en Algoritmos

Como lo hemos hablado en anteriores artículos, los ciclos repetitivos son instrucciones muy poderosas, que de no contar con ellas estaríamos obligados a escribir muchas líneas de código adicionales, por ende el desarrollo de aplicaciones sería una tarea no tan agradable y menos ágil, en el día de hoy veremos la funcionalidad del ciclo o función para en algoritmos, dicha función está presente en múltiples lenguajes de programación que por lo general llevará la misma estructura que aquí estudiaremos,  veamos:

¿Para que Sirve?

El ciclo para sirve para repetir un proceso, comando o lista de comandos un determinado número de veces, hasta alcanzar el tope que estipulemos donde se dará fin al proceso de repetición o iteración, Actualmente este ciclo es el más usado en el desarrollo de Software.

Diferencias entre el Ciclo para y Ciclo Mientras que (For y While)

Es una pregunta muy común al momento de conocer ambos ciclos, básicamente la diferencia se radica en la forma de operar de los ciclos, así:

Ciclo para (For):

  • Las instrucciones se repiten hasta lograr que la condición establecida en el ciclo sea verdadera, lo que quiere decir que mientras la condición dada sea falsa las instrucciones seguirán repitiéndose.
  • Se ejecuta un número fijo de veces.

Ciclo mientras que (While):

  • Las instrucciones se repiten si y solo si la condición del ciclo es verdadera.
  • Se ejecuta un numero infinito de veces.

Estructura del Ciclo Para

Veamos la estructura de este ciclo teniendo como referencia el desarrollo de algoritmos en PSeInt:

 Algoritmo Ejemplo_ciclo_para
 Para variable_numerica<-valor_inicial Hasta valor_final Con Paso paso Hacer
 secuencia_de_acciones
 Fin Para
 FinAlgoritmo

Detalles y Análisis:
{variable_numerica}: Identificador de la variable que se utilizará para iterar.
{valor_inicial}: Valor de {variable_numerica} desde el cual se comenzará a iterar.
{valor_final}: Valor final de {variable_numerica} hasta el cual se continuará iterando.
{paso}: Incremente que se debe realizar a {variable_numerica} en cada iteración.
{secuencia_de_acciones}: Lista de instrucciones que desea repetir en cada iteración.

Representación en diagrama de flujo:

Veamos como sería la representación de este ciclo de forma gráfica en un diagrama de flujo.

ciclo para

Ejemplos (Algoritmos) Generar Números del 1 al 100

Algoritmo Ejemplo_ciclo_para
 Para i<-1 Hasta 100 Con Paso 1 Hacer
 Escribir "",i
 Fin Para
FinAlgoritmo

Al probar el algoritmo anterior obtendremos el listado de números del 1 al 100, una forma mucho más rápida de generar dichos números que de otra forma sería escribiendo 100 veces la instrucción “Escribir”.

Ejemplo (Algoritmos) Saludar 10 Veces

Algoritmo Ejemplo_ciclo_para
 Para i<-1 Hasta 10 Con Paso 1 Hacer
 Escribir "Saludo Número ",i
 Fin Para
FinAlgoritmo

Uso en Diferentes Lenguajes de programación:

La implementación de este ciclo en diversos lenguajes de programación se realiza de forma similar y mucho más en los lenguajes que han sido influenciados de algún modo por otros, siguiendo la estructura y solo diferenciándose en el uso o declaración de variables, mensajes, separadores y llaves, veamos:

En JAVA:

 for (int i = 0; i < 10; i++) {
 System.out.println("Valor: "+i);
 }

En JavaScript:

for (var i = 0; i < 10; i++) {
 console.log("Valor "+i)
 }

En PHP:

for ($i=0; $i < ; $i++) { 
 echo "Valor: ".$i;
 }

Como apreciamos en estos tres lenguajes el uso es prácticamente el mismo, teniendo solo en cuenta las especificaciones en sintaxis de cada lenguaje.

 

Si este post fue de ayuda para ti, no olvides dejar un comentario, también puedes contar tu experiencia o lo que estés haciendo. Nos ayuda a seguir creciendo. ¡Vamos!, solo te llevará 1 minuto.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *