Algoritmos en pseint

Cuando empezamos el aprendizaje de una asignatura, es necesario hacer todas las pruebas b√°sicas posibles; esto mismo es aplicable a los algoritmos, antes de realizar ejercicios, es importante hacer peque√Īas pruebas con mensajes y variables, que nos permitan ir comprendiendo el funcionamiento; y no sobre entender que ya conocemos lo que debemos hacer, este es un error de algunos docentes e inclusive de muchos estudiantes; hoy veremos c√≥mo¬†crear un algoritmo para mostrar un saludo por pantalla; uno de los pasos b√°sicos que debes comprender, para iniciar en el desarrollo de algoritmos en PSeInt.

Crear un algoritmo para mostrar un saludo por pantalla en PSeInt

 

Mostrar mensajes en PseInt o algoritmos, es fundamental, para dos cosas:

  • Indicar los datos que se deben ingresar.
  • Mostrar las salidas o resultados de un algoritmo.

Veamos a continuación, ejemplos de mensajes en PSeInt con algunas variaciones.

SUSCR√ćBETE GRATIS AQU√欆y sigue haciendo m√°s ejercicios de¬†PSeInt; que ayudar√°n en tus clases.

1. Mostrando un mensaje simple

Algoritmo Mensajes
Escribir "Hola, bienvenido a PSeInt"
FinAlgoritmo

El algoritmo anterior, al ejecutarlo, retorna o muestra el mensaje; ¬ęHola, bienvenido a PSeInt¬Ľ; por lo tanto, ya sabemos que si deseamos ¬ęimprimir¬Ľ por pantalla, un texto, utilizamos el comando escribir.

2. Mostrando un mensaje con el valor de una variable creada

Algoritmo Mensajes
Definir num Como Entero
num <- 90
Escribir "El n√ļmero es: ",num
FinAlgoritmo

El ejemplo anterior, lo que hace es mostrar el mensaje: El n√ļmero es: 90, esta es una forma de ¬ęconcatenar¬Ľ, un mensaje con el valor de una variable. Este es un recurso muy √ļtil y necesario cuando realizamos algoritmos.

3. Mostrar un mensaje con un valor ingresado

Algoritmo Mensajes
Definir nombre Como Caracter
Escribir "Ingrese su nombre"
leer nombre
Escribir "Hola ",nombre,", ¬ŅC√≥mo est√°s?"
FinAlgoritmo

Si ejecutamos este ejemplo, obtenemos el siguiente resultado:

*** Ejecución Iniciada. ***
Ingrese su nombre
> José
Hola Jos√©, ¬ŅC√≥mo est√°s?
*** Ejecución Finalizada. ***

Si observas, este ejemplo es parecido al anterior, con la diferencia que el valor de la variable nombre; es ingresado al momento de ejecutar el algoritmo.

Los datos ingresados son fundamentales; se les llama datos de entrada y los algoritmos los utilizan para realizar c√°lculos de valores esperados, pero que pueden tomar muchos valores; por ejemplo, una calculadora, si lo piensas, siempre est√°n esperando n√ļmeros, para poder realizar una operaci√≥n, as√≠ mismo funcionan los algoritmos y programas.

Observa este vídeo dónde podrás comprender fácilmente el uso de datos de entrada o variables

Mejora tus conocimientos

¬†‚ě°¬†Observa explicaciones detalladas de conceptos de algoritmo y programaci√≥n en el¬†DICCIONARIO DE ALGORITMOS; en un¬†lenguaje sencillo,¬†sin¬†complicaciones¬†y lo mejor gratis.


¬†‚ě°¬†¬†Recuerda que si deseas¬†aprender m√°s de algoritmos, accede al¬†curso gratuito¬†de¬†¬†PSeInt, donde te explicar√©¬†paso a paso¬†ejercicios pr√°cticos, para tus tareas.

ūüĎȬ†INGRESA AQU√ć.

 

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

×