Algoritmo Triangulo Isósceles, Escaleno y Equilatero Ejercicio validación

Se plantea el desarrollo de un algoritmo que valide el tipo de triangulo (algoritmo triangulo isósceles escaleno equilatero) que se obtiene a partir de los lados ingresados, los cuales serán los lados del triángulo, teniendo en cuenta como es cada triángulo, veamos:

Algoritmo Triangulo Isósceles Escaleno Equilatero

Desarrollo del PseudoCodigo

Algoritmo Validar_Triangulo
    Escribir "Ingrese el Primer Lado"
    leer l1
    Escribir "Ingrese el Segundo Lado"
    Leer l2
    Escribir "Ingrese el Tercer Lado"
    Leer l3
    si(l1==l2) y (l1==l3) Entonces
        Escribir "El Triangulo es Equilatero"
    Sino
        si(l1==l2) o (l2==l3) o (l1==l3) Entonces
            Escribir "El Triangulo es Isósceles"
        Sino
            Escribir "El Triangulo es Escaleno"
        FinSi
    FinSi
FinAlgoritmo
  1. Lo primero que hacemos es solicitar los tres lados ya que estos son nuestros datos de entrada.
  2. Haciendo uso de condicionales anidados logramos solo ejecutar las instrucciones en caso de que la condición se cumpla, evitando validar todos los “si” para todos los casos.

Nota: Este es un ejercicio muy común en el aprendizaje de algoritmos debido a que nos permite ver a simple vista la forma de operar de los condicionales y la importancia del buen uso de los operadores de relación.