Algoritmo Triángulo Isósceles Escaleno y Equilátero Ejercicio validación

Se plantea el desarrollo de un algoritmo que valide el tipo de triangulo (algoritmo triangulo isósceles escaleno equilatero) que se obtiene a partir de los lados ingresados, los cuales serán los lados del triángulo, teniendo en cuenta como es cada triángulo, veamos:

Algoritmo Triangulo Isósceles Escaleno Equilatero en PSeInt

Caso: Escribir un algoritmo, que solicite los tres lados de un triángulo, a continuación deberá mostrar si es isóceles, escaleno o equilátero.

A continuación encuentras el código de este algoritmo, analízalo completamente, para comprender su funcionamiento; lo importante, es identificar el papel que juegan los condicionales, para determinar, cada triángulo.

Desarrollo del PseudoCodigo

🛡 Los ataques informáticos crecen cada día
YouTube IconProtege tus Dispositivos - Usa Kaspersky Antivirus.
Algoritmo Validar_Triangulo    
Escribir "Ingrese el Primer Lado"    
leer l1    
Escribir "Ingrese el Segundo Lado"    
Leer l2    
Escribir "Ingrese el Tercer Lado"    
Leer l3    
si(l1==l2) y (l1==l3) Entonces        
Escribir "El Triangulo es Equilatero"    
Sino        
si(l1==l2) o (l2==l3) o (l1==l3) Entonces            
Escribir "El Triangulo es Isósceles"        
Sino            
Escribir "El Triangulo es Escaleno"        
FinSi    
FinSiFinAlgoritmo

Análisis del código

  1. Lo primero que hacemos es solicitar los tres lados ya que estos son nuestros datos de entrada.
  2. Haciendo uso de condicionales anidados logramos solo ejecutar las instrucciones en caso de que la condición se cumpla, evitando validar todos los «si» para todos los casos.

Nota: Este es un ejercicio muy común en el aprendizaje de algoritmos debido a que nos permite ver a simple vista la forma de operar de los condicionales y la importancia del buen uso de los operadores de relación.

✅ Recuerda que puedes observar más ejercicios de PSeInt explicados paso a paso en mi canal de YouTube, haciendo clic aquí.

2 comentarios

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *