Algoritmo que calcula el Índice de masa corporal en PSeInt

Ciencia, Algoritmos

Para el día de hoy veremos un algoritmo que calcula el índice de masa corporal, esto con el fin de conocer la aplicabilidad de los algoritmos y programación en diversas disciplinas; en anteriores artículos hemos incursionado un poco en el mundo contable y como no hacerlo en el aspecto médico, veamos los pormenores de este ejercicio.

Algoritmo que calcula el Índice de masa corporal en PSeInt

¿Qué es el índice de masa corporal?

Mediante el IMC o Índice de masa corporal podemos determinar la medida de obesidad en una persona; esto se puede lograr dividiendo su peso entre su estatura al cuadrado, teniendo en cuenta el resultado de esta operación, verificamos en la escala el nivel de obesidad.

Escala de Obesidad IMC

Composición corporal Índice de masa corporal (IMC)
Peso inferior al normal Menos de 18.5
Normal 18.5 – 24.9
Peso superior al normal 25.0 – 29.9
Obesidad Más de 30.0

Construyendo el algoritmo.

Detalle del caso estudio: Construir un algoritmo que determine el IMC (Índice de masa corporal) en una persona, para esto se solicitan los siguientes datos:

  • Estatura (En metros ej: 1.76).
  • Peso (En Kg.).

Posteriormente mostrar el resultado obtenido (IMC); especialmente la escala o composición corporal.

Datos de entrada.

  • Estatura.
  • Peso.

Procesos

  • Determinar el IMC con la fórmula: IMC=Peso/Estatura[2].
  • Determinar la escala o composición corporal.

Salida

  • En primer lugar Mostrar el valor del IMC.
  • En segundo lugar Mostrar la escala o composición corporal según la tabla.

Código del algoritmo

Algoritmo I_M_C
 Definir peso, estatura, imc Como Real
 Escribir "Ingrese su Peso (En KG): "
 leer peso
 Escribir "Ingrese su Estatura (En Mts): "
 leer estatura
 imc <- peso / (estatura * estatura)
 Escribir "Su IMC es de: ",imc
 si(imc < 18.5) Entonces
 Escribir "Peso inferior al normal"
 Sino
 si(imc>=18.5 y imc <=24.9) Entonces
 Escribir "Normal"
 Sino
 si(imc>=25.0 y imc<=30) Entonces
 Escribir "Peso superior al normal"
 Sino
 Escribir "Obesidad"
 FinSi
 FinSi
 FinSi
FinAlgoritmo

En el código anterior solicitamos los datos de entrada, realizamos la formula con estos; finalmente haciendo uso de condicionales, mostramos la escala determinada teniendo en cuenta la tabla del IMC, como resultado logramos mostrar el IMC, además la composición corporal de la persona.

Salida de algoritmo

Como resultado de la ejecución del código obtendríamos:

*** Ejecución Iniciada. ***
Ingrese su Peso (En KG):
> 82
Ingrese su Estatura (En Mts):
> 1.79
Su IMC es de: 25.592209981
Peso superior al normal
*** Ejecución Finalizada. ***