Promedio de Notas en PSeInt Ejercicio Algoritmos en PSeInt

Algoritmos

Al iniciar en el desarrollo de algoritmos hay ejercicios que ayudan a la compresión de los aspectos principales de estos, un ejercicio muy común es calcular promedios, normalmente de nota de estudiantes lo cual facilita la aplicación del algoritmo a un problema común en la vida real (Promedio de notas en PSeInt), en esta entrada daremos solución al siguiente enunciado:

Ejercicio: Promedio de Notas en PSeInt Ejercicio

Juan es un estudiante que desea saber su promedio de notas de seis actividades enviadas a su profesor, escribir un algoritmo que realice esta operación y le diga a juan Si ganó o perdió la materia.

Como podemos darnos cuenta el ejercicio establece un condicional, el cual indica que debemos validar el resultado obtenido para saber si Juan gana o pierde la materia, veamos:

Veamos un ejemplo para el cálculo del promedio en PSeInt

Algoritmo sin_titulo
Escribir 'Ingrese su primera nota'
leer nota1
Escribir 'Ingrese su segunda nota'
Leer nota2
Escribir 'Ingrese su tercera nota'
Leer nota3
Escribir 'Ingrese su cuarta nota'
Leer nota4
Escribir 'Ingrese su quinta nota'
Leer nota5
Escribir 'Ingrese su sexta nota'
Leer nota6
total < - (nota1+nota2+nota3+nota4+nota5+nota6)/6 Escribir 'Su promedio es: ', total Si (total >= 3) Entonces
Escribir 'Felicidades usted gano la materia'
Sino
Escribir 'Usted perdio la materia :('
Fin Si
FinAlgoritmo

Actualización: CALCULAR PROMEDIO DE N ALUMNOS en PSeInt


En este vídeo, podrás observar paso a paso, cómo calcular el promedio de un grupo de estudiantes; aplicando ciclos, variables contadoras, acumuladoras y arreglos (Dimensiones) en algoritmos con PSeInt.

Recordando el uso de condicionales:

Los condicionales permiten redirigir el flujo de un algoritmo o de un programa para realizar acciones; teniendo en cuenta un valor o resultado de una operación, estas condiciones son tomadas en base a operadores:
promedio de notas ejercicio algoritmo

promedio de notas ejercicio algoritmo

Recuerda que puedes ver más vídeos como este en el curso de algoritmos gratuito, 👉 en este enlace.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *