Promedio de Notas Ejercicio Algoritmo

Algoritmos

Al iniciar en el desarrollo de algoritmos hay ejercicios que ayudan a la compresión de los aspectos principales de estos, un ejercicio muy común es calcular promedios, normalmente de nota de estudiantes lo cual facilita la aplicación del algoritmo a un problema común en la vida real, en esta entrada daremos solución al siguiente enunciado:

Ejercicio

Juan es un estudiante que desea saber su promedio de notas de seis actividades enviadas a su profesor, escribir un algoritmo que realice esta operación y le diga a juan Si ganó o perdió la materia.

Como podemos darnos cuenta el ejercicio establece un condicional, el cual indica que debemos validar el resultado obtenido para saber si Juan gana o pierde la materia, veamos:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
Algoritmo sin_titulo
    Escribir 'Ingrese su primera nota'
    leer nota1
    Escribir 'Ingrese su segunda nota'
    Leer nota2
    Escribir 'Ingrese su tercera nota'
    Leer nota3
    Escribir 'Ingrese su cuarta nota'
    Leer nota4
    Escribir 'Ingrese su quinta nota'
    Leer nota5
    Escribir 'Ingrese su sexta nota'
    Leer nota6
    total < - (nota1+nota2+nota3+nota4+nota5+nota6)/6
    Escribir 'Su promedio es: ', total
    Si (total >= 3) Entonces
        Escribir 'Felicidades usted gano la materia'
    Sino
        Escribir 'Usted perdio la materia :('
    Fin Si
FinAlgoritmo


Recordando el uso de condicionales:

Los condicionales permiten redirigir el flujo de un algoritmo o de un programa para realizar acciones teniendo en cuenta un valor o resultado de una operación, estas condiciones son tomadas en base a operadores: